blob: 5fbf0645e08e5433808322258c4b55162136fd0f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Open-LLDP"
2DESCRIPTION = "Link Layer Discovery Protocol for Linux that includes support for DCBX"
3HOMEPAGE = "http://open-lldp.org/start"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8c2bc283e65df398ced5f5b747e78162"
7
8S = "${WORKDIR}/git"
9
10inherit pkgconfig autotools
11inherit ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}
12
13DEPENDS = "libnl libconfig readline"
14
15SRCREV = "36d729de7ce5b56cf061d94d610cf0510154820c"
16SRC_URI = "git://github.com/intel/openlldp.git;protocol=https;branch=master \
17 file://0001-Fix-musl-libc-build-issue.patch \
18 file://0001-autotools-Add-include-path-to-generated-version.h.patch \
19 file://0001-autotools-Add-option-to-disable-installation-of-syst.patch \
20 "
21
22# Makefile.am adds -Werror to AM_CFLAGS. There are warnings so disable it.
23TARGET_CFLAGS += "-Wno-error"
24
25# Enable install of systemd conf files.
26EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_system_unitdir}', '', d)}"
27
28SYSTEMD_SERVICE_${PN} = "lldpad.service lldpad.socket"
29
30# To enable service at boot set to enable in local.conf.
31SYSTEMD_AUTO_ENABLE ?= "disable"
32
33RRECOMMENDS_${PN} = "iproute2-tc"