blob: b83f68f8c122c85944b02d6e0592f5db80693b24 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
3DRBD mirrors a block device over the network to another machine.\
4Think of it as networked raid 1. It is a building block for\
5setting up high availability (HA) clusters."
6HOMEPAGE = "http://www.drbd.org/"
7SECTION = "admin"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
10
11SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
12 git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
13 ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-drbd-utils-support-usrmerge.patch','',d)} \
14 "
15# v9.12.0
16SRCREV_drbd-utils = "91629a4cce49ca0d4f917fe0bffa25cfe8db3052"
17SRCREV_drbd-headers = "233006b4d26cf319638be0ef6d16ec7dee287b66"
18
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
22
23SYSTEMD_SERVICE_${PN} = "drbd.service"
24SYSTEMD_AUTO_ENABLE = "disable"
25
26DEPENDS = "flex-native"
27
28inherit autotools-brokensep systemd
29
30EXTRA_OECONF = " \
31 --with-initdir=/etc/init.d \
32 --without-pacemaker \
33 --without-rgmanager \
34 --without-bashcompletion \
35 --with-distro debian \
36 --with-initscripttype=both \
37 --with-systemdunitdir=${systemd_unitdir}/system \
38 --without-manual \
39 "
40
41# If we have inherited reproducible_build, we want to use it.
42export WANT_DRBD_REPRODUCIBLE_BUILD = "yes"
43
44do_install_append() {
45 # don't install empty /var/lock and /var/run to avoid conflict with base-files
46 rm -rf ${D}${localstatedir}/lock
47 rm -rf ${D}${localstatedir}/run
48}
49
50RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
51
52# The drbd items are explicitly put under /lib when installed.
53#
54FILES_${PN} += "/run"
55FILES_${PN} += "${nonarch_base_libdir}/drbd \
56 ${nonarch_libdir}/drbd \
57 ${nonarch_libdir}/tmpfiles.d"
58FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"