blob: a63e49ec558b1ae8036497cc4f582a806e4f66b7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "nbdkit is a toolkit for creating NBD servers."
2DESCRIPTION = "NBD — Network Block Device — is a protocol \
3for accessing Block Devices (hard disks and disk-like things) \
4over a Network. \
5\
6nbdkit is a toolkit for creating NBD servers."
7
8HOMEPAGE = "https://github.com/libguestfs/nbdkit"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=4332a97808994cf2133a65b6c6f33eaf"
11
12SRC_URI = "git://github.com/libguestfs/nbdkit.git;protocol=https \
13 file://0001-server-Fix-build-when-printf-is-a-macro.patch \
14"
15
16PV = "1.19.6+git${SRCPV}"
17SRCREV = "257561bc9f2f01eb9f21686bcec4b863d17a26c4"
18
19S = "${WORKDIR}/git"
20
21DEPENDS = "curl xz e2fsprogs zlib"
22
23# autotools-brokensep is needed as nbdkit does not support build in external directory
24inherit pkgconfig python3native perlnative bash-completion autotools-brokensep
25
26# Those are required to build standalone
27EXTRA_OECONF = " --without-libvirt --without-libguestfs --disable-perl"
28
29# Disable some extended support (not desired for small embedded systems)
30#EXTRA_OECONF += " --disable-python"
31#EXTRA_OECONF += " --disable-ocaml"
32#EXTRA_OECONF += " --disable-rust"
33#EXTRA_OECONF += " --disable-ruby"
34#EXTRA_OECONF += " --disable-tcl"
35#EXTRA_OECONF += " --disable-lua"
36#EXTRA_OECONF += " --disable-vddk"