blob: 8c97662df5a72cac12e707c033cd7c36d51f9a5c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0 & LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
8SRCREV = "95ec1ab31ee97411fc37156d12061adcf0331598"
9PV = "1.5.3+git${SRCPV}"
10
11SRC_URI = "git://github.com/cminyard/gensio;protocol=https \
12 file://0001-filter-Rename-some-variables-to-tr_stdxxx.patch \
13 "
14
15S = "${WORKDIR}/git"
16
17inherit autotools
18
19PACKAGECONFIG ??= "openssl tcp-wrappers"
20
21PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
22PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
23PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
24
25EXTRA_OECONF = "--without-python"
26
27RDEPENDS_${PN} += "bash"