blob: 0e0ddd5779b001f877a52b17febd0662ba7ccf31 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Open-source monitoring solution for your IT infrastructure"
2DESCRIPTION = "\
3ZABBIX is software that monitors numerous parameters of a network and the \
4health and integrity of servers. ZABBIX uses a flexible notification \
5mechanism that allows users to configure e-mail based alerts for virtually \
6any event. This allows a fast reaction to server problems. ZABBIX offers \
7excellent reporting and data visualisation features based on the stored \
8data. This makes ZABBIX ideal for capacity planning. \
9\
10ZABBIX supports both polling and trapping. All ZABBIX reports and \
11statistics, as well as configuration parameters are accessed through a \
12web-based front end. A web-based front end ensures that the status of \
13your network and the health of your servers can be assessed from any \
14location. Properly configured, ZABBIX can play an important role in \
15monitoring IT infrastructure. This is equally true for small \
16organisations with a few servers and for large companies with a \
17multitude of servers."
18HOMEPAGE = "http://www.zabbix.com/"
19SECTION = "Applications/Internet"
20LICENSE = "GPLv2+"
21LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
22DEPENDS = "libevent libpcre openldap virtual/libiconv zlib"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \
27 file://0001-Fix-configure.ac.patch \
28 file://zabbix-agent.service \
29"
30
31SRC_URI[md5sum] = "e666539220be93b1af38e40f5fbb1f79"
32SRC_URI[sha256sum] = "22bb28e667424ad4688f47732853f4241df0e78a7607727b043d704ba726ae0e"
33
34inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
35
36SYSTEMD_PACKAGES = "${PN}"
37SYSTEMD_SERVICE_${PN} = "zabbix-agent.service"
38SYSTEMD_AUTO_ENABLE = "enable"
39
40USERADD_PACKAGES = "${PN}"
41GROUPADD_PARAM_${PN} = "-r zabbix"
42USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \
43 -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
44"
45
46KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
47
48EXTRA_OECONF = " \
49 --enable-dependency-tracking \
50 --enable-agent \
51 --enable-ipv6 \
52 --with-net-snmp \
53 --with-ldap=${STAGING_EXECPREFIXDIR} \
54 --with-unixodbc \
55 --with-ssh2 \
56 --with-sqlite3 \
57 --with-zlib \
58 --with-libpthread \
59 --with-libevent \
60 --with-libpcre \
61"
62CFLAGS_append = " -lldap -llber -pthread"
63
64do_configure_prepend() {
65 export KERNEL_VERSION="${KERNEL_VERSION}"
66}
67
68do_install_append() {
69 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
70 install -d ${D}${systemd_unitdir}/system
71 install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
72 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
73 fi
74}
75
76FILES_${PN} += "${libdir}"
77
78RDEPENDS_${PN} = "logrotate"