blob: 4617da8e1bf9b51527c13b4acef738c2fbec0795 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Python interface to MySQL"
2HOMEPAGE = "https://github.com/farcepest/MySQLdb1"
3SECTION = "devel/python"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://GPL-2.0;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "mysql5"
8
9SRCNAME = "MySQL-python"
10
Brad Bishop19323692019-04-05 15:28:33 -040011SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.zip \
12 file://0001-_mysql.c-fix-compilation-with-MariaDB-with-10.3.13.patch \
13"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014SRC_URI[md5sum] = "654f75b302db6ed8dc5a898c625e030c"
15SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e140c74"
16
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
Andrew Geissler82c905d2020-04-13 13:39:40 -050019inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "setuptools", "", d)}
20
21python() {
22 if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
23 raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
24}