blob: 9a44133c5605a3a2bf80413693756352eda0af87 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Abseil is a cpp library like STL"
2DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
3additional useful libraries like algorithm, container, debugging, hash, memory, \
4meta, numeric, strings, synchronization, time, types and utility"
5HOMEPAGE = "https://abseil.io/"
6SECTION = "libs"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
9
10PV = "20190808+git${SRCPV}"
11SRCREV = "aa844899c937bde5d2b24f276b59997e5b668bde"
12BRANCH = "lts_2019_08_08"
13SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH} \
14 file://0001-Remove-maes-option-from-cross-compilation.patch \
15 file://0002-Add-forgotten-ABSL_HAVE_VDSO_SUPPORT-conditional.patch \
16 file://0003-Add-fPIC-option.patch \
17 file://0001-Add-RISCV-support-to-GetProgramCounter.patch \
18 file://0001-absl-always-use-asm-sgidefs.h.patch \
19 "
20
21S = "${WORKDIR}/git"
22
23DEPENDS_append_libc-musl = " libexecinfo "
24
25ASNEEDED_class-native = ""
26ASNEEDED_class-nativesdk = ""
27
28inherit cmake
29
30BBCLASSEXTEND = "native nativesdk"
31ALLOW_EMPTY_${PN} = "1"
32
33python () {
34 arch = d.getVar("TARGET_ARCH")
35
36 if arch == "aarch64":
37 tunes = d.getVar("TUNE_FEATURES")
38 if not tunes:
39 raise bb.parse.SkipPackage("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
40 return
41 pkgn = d.getVar("PN")
42 pkgv = d.getVar("PV")
43 if "crypto" not in tunes:
44 raise bb.parse.SkipPackage("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
45
46 if arch == "x86_64":
47 tunes = d.getVar("TUNE_FEATURES")
48 if not tunes:
49 raise bb.parse.SkipPackage("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
50 return
51 pkgn = d.getVar("PN")
52 pkgv = d.getVar("PV")
53 if "corei7" not in tunes:
54 raise bb.parse.SkipPackage("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
55
56}
57