blob: c31cef63cf41665d764e8bbfbce855f86e198bf6 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Memory Efficient Serialization Library"
2HOMEPAGE = "https://github.com/google/flatbuffers"
3SECTION = "console/tools"
4LICENSE = "Apache-2.0"
5
6PACKAGE_BEFORE_PN = "${PN}-compiler"
7
8RDEPENDS_${PN}-compiler = "${PN}"
9RDEPENDS_${PN}-dev += "${PN}-compiler"
10
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
12
13SRCREV = "6df40a2471737b27271bdd9b900ab5f3aec746c7"
14
15SRC_URI = "git://github.com/google/flatbuffers.git"
16
17# Make sure C++11 is used, required for example for GCC 4.9
18CXXFLAGS += "-std=c++11 -fPIC"
19BUILD_CXXFLAGS += "-std=c++11 -fPIC"
20
21# BUILD_TYPE=Release is required, otherwise flatc is not installed
22EXTRA_OECMAKE += "\
23 -DCMAKE_BUILD_TYPE=Release \
24 -DFLATBUFFERS_BUILD_TESTS=OFF \
25 -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
26"
27
28inherit cmake
29
30S = "${WORKDIR}/git"
31
32FILES_${PN}-compiler = "${bindir}"
33
34BBCLASSEXTEND = "native nativesdk"