blob: 36659e752d111b6946b64ad772dd667eb8f00033 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A library to handle Apple Property List format whereas it's binary or XML"
2
3LICENSE = "GPLv2 & LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \
5 file://COPYING.LESSER;md5=6ab17b41640564434dda85c06b7124f7"
6
Andrew Geissler82c905d2020-04-13 13:39:40 -05007DEPENDS = "libxml2 glib-2.0 swig python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Andrew Geissler82c905d2020-04-13 13:39:40 -05009inherit autotools pkgconfig python3native
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010
Brad Bishope42b3e32020-01-15 22:08:42 -050011SRCREV = "3df02d4d0e9008771e8622fdc10de8333b3f0d85"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \
13 "
14
15S = "${WORKDIR}/git"
16
17do_install_append () {
18 if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then
19 chrpath -d ${D}${libdir}/python*/site-packages/plist/_plist.so
20 fi
21}
22
23PACKAGES =+ "${PN}-utils ${PN}++ ${PN}-python"
24FILES_${PN} = "${libdir}/libplist${SOLIBS}"
25FILES_${PN}++ = "${libdir}/libplist++${SOLIBS}"
26FILES_${PN}-utils = "${bindir}/*"
27FILES_${PN}-python = "${libdir}/python*/site-packages/*"
28
29