blob: 6ea632d06448467a1ae93e9ac60ba0416f86bb3e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "RenderDoc recipe providing renderdoccmd"
2DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
3HOMEPAGE = "https://github.com/baldurk/renderdoc"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=df7ea9e196efc7014c124747a0ef9772"
6
7SRCREV = "a56af589d94dc851809fd5344d0ae441da70c1f2"
8SRC_URI = "git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
9 file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
10 file://0001-Remove-glslang-pool_allocator-setAllocator.patch \
11"
12S = "${WORKDIR}/git"
13
14DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
15
16RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
17
18inherit cmake python3native features_check
19
20REQUIRED_DISTRO_FEATURES = "x11 opengl"
21
22python __anonymous () {
23 # only works on glibc systems
24 if d.getVar('TCLIBC') != "glibc":
25 raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
26}
27
28COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
29
30EXTRA_OECMAKE += "\
31 -DENABLE_QRENDERDOC=OFF \
32 -DENABLE_PYRENDERDOC=OFF \
33 -DENABLE_RENDERDOCCMD=ON \
34 -DCMAKE_BUILD_TYPE=Release \
35"
36
37FILES_${PN} += "${libdir}"
38FILES_${PN}-dev = "${includedir}"