blob: 05dc94a990d0ade336350bea24446524a14c0a41 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "open-source formatting library for C++"
2DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
3HOMEPAGE = "https://fmt.dev"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=af88d758f75f3c5c48a967501f24384b"
6
7SRC_URI += "git://github.com/fmtlib/fmt"
8SRCREV = "9bdd1596cef1b57b9556f8bef32dc4a32322ef3e"
9
10S = "${WORKDIR}/git"
11
12inherit cmake
13inherit ptest
14
15EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"