blob: 590c4ebc28844d1867e8b26258cad3779313681e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# Released under the MIT license.
2
3SUMMARY = "Mimetic Library for multi-part parsing"
4DESCRIPTION = "Email library (MIME) written in C++ designed to be easy to use and integrate but yet fast and efficient."
5AUTHOR = "Stefano Barbato <stefano@codesink.org>"
6HOMEPAGE = "http://www.codesink.org/mimetic_mime_library.html"
7BUGTRACKER = "https://github.com/LadislavSopko/mimetic/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=b49da7df0ca479ef01ff7f2d799eabee"
11
12SRCREV = "50486af99b4f9b35522d7b3de40b6ce107505279"
13SRC_URI += "git://github.com/LadislavSopko/mimetic/ \
14 file://0001-libmimetic-Removing-test-directory-from-the-Makefile.patch \
15 file://0001-mimetic-Check-for-MMAP_FAILED-return-from-mmap.patch \
16 "
17
18UPSTREAM_CHECK_COMMITS = "1"
19
20S = "${WORKDIR}/git"
21
22CXXFLAGS += "-Wno-narrowing"
23
24inherit autotools