blob: 39629cce0d39efe8b150214fbc7646645b8c482d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Very fast, header only, C++ logging library."
2HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRCREV = "cf6f1dd01e660d5865d68bf5fa78f6376b89470a"
7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=git;branch=v1.x;"
8
9S = "${WORKDIR}/git"
10
11BBCLASSEXTEND = "native"
12# no need to build example&text&benchmarks on pure yocto
13EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_EXAMPLES=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off"
14
15inherit cmake
16
17# Header-only library
18RDEPENDS_${PN}-dev = ""
19RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"