blob: fc9786beca18063f14a6a4d6d8a6236192d88ce1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Perl library for transparent SSL"
2DESCRIPTION = "This module is a true drop-in replacement for IO::Socket::INET that \
3uses SSL to encrypt data before it is transferred to a remote server \
4or client. IO::Socket::SSL supports all the extra features that one \
5needs to write a full-featured SSL client or server application: \
6multiple SSL contexts, cipher selection, certificate verification, and \
7SSL version selection. As an extra bonus, it works perfectly with \
8mod_perl."
9HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/"
10SECTION = "libs"
11
12LICENSE = "Artistic-1.0|GPLv1+"
13LIC_FILES_CHKSUM = "file://META.yml;beginline=12;endline=12;md5=963ce28228347875ace682de56eef8e8"
14
15RDEPENDS_${PN} += "\
16 libnet-ssleay-perl \
17 perl-module-autoloader \
18 perl-module-scalar-util \
19 perl-module-io-socket \
20"
21
22SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz \
23 file://run-ptest \
24 "
25SRC_URI[md5sum] = "4230c829c8875889848093b2b46a7284"
26SRC_URI[sha256sum] = "4420fc0056f1827b4dd1245eacca0da56e2182b4ef6fc078f107dc43c3fb8ff9"
27
28S = "${WORKDIR}/IO-Socket-SSL-${PV}"
29
30inherit cpan ptest
31
32do_install_append () {
33 mkdir -p ${D}${docdir}/${PN}/
34 cp ${S}/BUGS ${D}${docdir}/${PN}/
35 cp ${S}/Changes ${D}${docdir}/${PN}/
36 cp ${S}/README ${D}${docdir}/${PN}/
37 cp -pRP ${S}/docs ${D}${docdir}/${PN}/
38 cp -pRP ${S}/certs ${D}${docdir}/${PN}/
39 cp -pRP ${S}/example ${D}${docdir}/${PN}/
40}
41
42do_install_ptest () {
43 cp -r ${B}/t ${D}${PTEST_PATH}
44 cp -r ${B}/certs ${D}${PTEST_PATH}
45}
46
47BBCLASSEXTEND = "native"