blob: 802a5b2eaa68b77e84b52ea0d6b47f18dab4b26b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Arpeggio is a recursive descent parser with memoization based on PEG grammars (aka Packrat parser)"
2HOMEPAGE = "https://pypi.org/project/Arpeggio/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=33b8d1ba459a2fa4d801acfd1d1b7ceb"
5
6SRC_URI[md5sum] = "39667a626217c670bc634444be6e904a"
7SRC_URI[sha256sum] = "948ce06163a48a72c97f4fe79ad3d1c1330b6fec4f22ece182fb60ef60bd022b"
8
9PYPI_PACKAGE = "Arpeggio"
10inherit pypi setuptools3
11
12# setup.py of Arpeggio needs this.
13DEPENDS += "${PYTHON_PN}-pytest-runner-native"
14
15BBCLASSEXTEND = "native nativesdk"