blob: 768e557b94f7c458d8c911834c80771ca610dd2a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "DataStax Python Driver for Apache Cassandra"
2DESCRIPTION = "A modern, feature-rich and highly-tunable Python client \
3library for Apache Cassandra (1.2+) and DataStax Enterprise (3.1+) using \
4exclusively Cassandra's binary protocol and Cassandra Query Language v3."
5HOMEPAGE = "https://github.com/datastax/python-driver"
6SECTION = "devel/python"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
9SRCNAME = "cassandra-driver"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010
Andrew Geissler82c905d2020-04-13 13:39:40 -050011SRC_URI[md5sum] = "c5bed026bf48c821424c1f6296193908"
12SRC_URI[sha256sum] = "b65218e2582277f5b77d1436e420db8616f63e3437a9e839cdcd7172d760e861"
13
14DISTUTILS_BUILD_ARGS += " \
15 --no-libev \
16"
17DISTUTILS_INSTALL_ARGS += " \
18 --no-libev \
19"
20
21inherit pypi setuptools3
22
23RDEPENDS_${PN} += "\
24 ${PYTHON_PN}-cython \
25 ${PYTHON_PN}-json \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 ${PYTHON_PN}-misc \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 ${PYTHON_PN}-multiprocessing \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028 ${PYTHON_PN}-numbers \
Andrew Geissler82c905d2020-04-13 13:39:40 -050029 ${PYTHON_PN}-six \
30 libevent \
31"
32
33DEPENDS += "\
34 ${PYTHON_PN}-cython \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035"