blob: 80785b8d4e9688a74b091fb3061cba3a3bc8eef9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Universal encoding detector for Python 2 and 3"
2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Andrew Geissler82c905d2020-04-13 13:39:40 -05005SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c"
6SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae"
7
8# setup.py of chardet needs this.
9DEPENDS += "${PYTHON_PN}-pytest-runner-native"
10
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-cli"
14FILES_${PN}-cli += " \
15 ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
16"
17
18RDEPENDS_${PN}-cli = "${PN} "
19
20RDEPENDS_${PN}_class-target += " \
21 ${PYTHON_PN}-logging \
22"
23
24BBCLASSEXTEND = "native nativesdk"