blob: 0636972ec9fe6fbadc2af90bf2d521b792973308 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
2HOMEPAGE = "https://github.com/aio-libs/multidict/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
5
Andrew Geissler82c905d2020-04-13 13:39:40 -05006inherit pypi setuptools3 ptest
Brad Bishop26bdd442019-08-16 17:08:17 -04007
Brad Bishop0e2770c2020-01-21 07:31:46 -05008SRC_URI[md5sum] = "22b46f759cf2cc3ca1d2c9f82cc9bb79"
9SRC_URI[sha256sum] = "d7d428488c67b09b26928950a395e41cc72bb9c3d5abfe9f0521940ee4f796d4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}