blob: bf362daa7c28cffb61252cd5bca436abcdc86c34 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A MutableSet that remembers its order, so that every entry has an index."
2HOMEPAGE = "http://github.com/LuminosoInsight/ordered-set"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=2b36be0d99854aa2ae292a800a7c1d4e"
5
Brad Bishop0e2770c2020-01-21 07:31:46 -05006SRC_URI[md5sum] = "6e12312c8dc4c90fe840e86e8a352644"
7SRC_URI[sha256sum] = "a7bfa858748c73b096e43db14eb23e2bc714a503f990c89fac8fab9b0ee79724"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Andrew Geissler82c905d2020-04-13 13:39:40 -05009inherit pypi setuptools3 ptest
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010
11DEPENDS += "python3-pytest-runner-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 cp -f ${S}/test.py ${D}${PTEST_PATH}/
23}