blob: d2f7be46cfc124d25f3cb6b70f1570c9f05022d0 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "JSON Web Token implementation in Python"
2DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
3 Original implementation was written by https://github.com/progrium"
4HOMEPAGE = "http://github.com/jpadilla/pyjwt"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c"
7
8SRC_URI[md5sum] = "a4712f980c008696e13e09504120b2a0"
9SRC_URI[sha256sum] = "8d59a976fb773f3e6a39c85636357c4f0e242707394cadadd9814f5cbaa20e96"
10
11PYPI_PACKAGE = "PyJWT"
12inherit pypi setuptools3
13
14RDEPENDS_${PN} = "${PYTHON_PN}-cryptography"
15
16BBCLASSEXTEND = "native nativesdk"