blob: 081e904e164eb920f0955b9b1cf1051fcd4e2fa6 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5 * Simple API to run reliable benchmarks \
6 * Automatically calibrate a benchmark for a time budget. \
7 * Spawn multiple worker processes. \
8 * Compute the mean and standard deviation. \
9 * Detect if a benchmark result seems unstable. \
10 * JSON format to store benchmark results. \
11 * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
16SRC_URI[md5sum] = "d9e894dc843bb7f0abff109931a29895"
17SRC_URI[sha256sum] = "c37690e810116a83a244dfeec47885e2f0475b4c450313904be3bc2cdaf6d50a"
18
19DEPENDS += "${PYTHON_PN}-six-native"
20
21PYPI_PACKAGE = "pyperf"
22inherit pypi setuptools3
23
24RDEPENDS_${PN} += "${PYTHON_PN}-misc"