blob: c28a0148bc4ea7b48f1842fa3ccf29b037a73c33 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4878a915709225bceab739bdc2a18e8d"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[md5sum] = "c3d84a465fc56a4edd52cca8873ac0df"
9SRC_URI[sha256sum] = "b02c06db6cf09c12dd25137e563b31700d3b80fcc4ad23abb7a315f2789819be"
10
11RDEPENDS_${PN}_class-target += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-doctest \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-pickle \
16 ${PYTHON_PN}-pprint \
17 ${PYTHON_PN}-threading \
18"
19
20BBCLASSEXTEND = "native nativesdk"
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
26RDEPENDS_${PN}-ptest += " \
27 ${PYTHON_PN}-pytest \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
34 cp -f ${S}/README.txt ${D}${PTEST_PATH}/
35
36}