blob: dee70a03f5b64b21e7b88799aae7905ab98cf032 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Drop-in replacement for smbus-cffi/smbus-python in pure Python"
2DESCRIPTION = "smbus2 is a drop-in replacement for smbus-cffi/smbus-python in pure Python"
3HOMEPAGE = "https://github.com/kplindegaard/smbus2"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7inherit pypi setuptools3
8
9SRC_URI[md5sum] = "d5ed5acc889b4770a84cc932853ed20a"
10SRC_URI[sha256sum] = "210e66eebe4d0b1fe836b3ec2751841942e1c4918c0b429b20a0e20a222228b4"
11
12CLEANBROKEN = "1"
13
14PYPI_PACKAGE = "smbus2"
15
16RDEPENDS_${PN} = "${PYTHON_PN}-ctypes ${PYTHON_PN}-fcntl"
17
18RDEPENDS_${PN} += "\
19 ${PYTHON_PN}-ctypes \
20 ${PYTHON_PN}-fcntl \
21"