blob: 56ab27e0f65b7306f6ac95de5a2ada7e8bd70e7b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD-4-Clause"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
10SRC_URI[md5sum] = "ecea94eedc70ba5127fdeb0665bcca0d"
11SRC_URI[sha256sum] = "2dc86fe0476e945e61483d614ceb2cf4f93b95282eb243bdf792621994360383"
12
13PYPI_PACKAGE = "supervisor"
14inherit pypi systemd setuptools3
15RDEPENDS_${PN} = "\
16 ${PYTHON_PN}-meld3 \
17"
18
19SRC_URI += "file://supervisord.conf \
20 file://supervisor.service \
21 "
22SYSTEMD_SERVICE_${PN} = "supervisor.service"
23
24do_install_append() {
25 install -d ${D}${sysconfdir}/supervisor
26 install -d ${D}${systemd_system_unitdir}
27
28 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
29 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
30}