blob: d078883249b6fa0e8cc278467df14b7ec1354d9a [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Makes working with XML feel like you are working with JSON"
2AUTHOR = "Martin Blech"
3HOMEPAGE = "https://github.com/martinblech/xmltodict"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
6
7SRC_URI[md5sum] = "ddb2bd078cef4f7e3021a578034ad941"
8SRC_URI[sha256sum] = "50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21"
9
10PYPI_PACKAGE = "xmltodict"
11
Andrew Geissler82c905d2020-04-13 13:39:40 -050012inherit pypi setuptools3 ptest
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS_${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}