blob: c114a6c8bcf1cf2ebce77278f26c5c3fd6c93812 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
2SECTION = "devel/python"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5"
5
6SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0"
7SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9"
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13inherit pypi setuptools3 ptest
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}