blob: 5e0f44e29677ec6aacbc4edfc1d9cf81f666758f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Easily themable notification daemon with transparency effects"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-notifyd"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = " \
6 dbus \
7 dbus-glib \
8 libnotify \
9 libxfce4util \
10 libxfce4ui \
11 xfconf \
12 xfce4-panel \
13"
14
15inherit xfce-app
16
17SRC_URI[md5sum] = "1724fcb635bbab44c9f62c69734e446d"
18SRC_URI[sha256sum] = "c1d126a81604ff967e4655f06427763bf559c338ba629c95cb9aa7f5d6dc8ba6"
19
20# Avoid trouble with other desktops e.g KDE which also ships dbus service named
21# org.freedesktop.Notifications
22EXTRA_OECONF = "--disable-dbus-start-daemon"
23
24do_compile_prepend() {
25 mkdir -p xfce4-notifyd xfce4-notifyd-config
26}
27
28FILES_${PN} += " \
29 ${systemd_user_unitdir} \
30 ${datadir}/xfce4 \
31 ${datadir}/themes \
32 ${datadir}/dbus-1 \
33 ${libdir}/xfce4 \
34"