blob: 7226b1a032166f29790fdbc815fce05a1d2d9a43 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Backup, restore, import, and export panel layouts"
2SECTION = "x11/application"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6inherit python3native gettext features_check
7
8REQUIRED_DISTRO_FEATURES = "x11"
9
10DEPENDS += "intltool-native"
11
12SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2 \
13 file://not-create-link-to-locale.patch \
14 "
15SRC_URI[md5sum] = "6190678bc701c197babcb2389ba46182"
16SRC_URI[sha256sum] = "a84d5e748d53bc5da269954cc3ad7f5ac0c4f5813acfd3892ea6f9064f17fb68"
17
18do_configure() {
19 # special configure - no autotools...
20 ./configure --prefix=${prefix}
21}
22
23do_install() {
24 oe_runmake 'DESTDIR=${D}' install
25 sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
26}
27
28FILES_${PN} += "${datadir}/metainfo"
29
30RDEPENDS_${PN} += "python3-pygobject python3-pexpect"