blob: 62f0640f09e82e284ab93cd63a3ff9601949d00c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Xfce screensaver Application"
2DESCRIPTION = "Xfce screensaver is a screen saver and locker that aims to have simple, sane, secure defaults and be well integrated with the desktop."
3HOMEPAGE = "https://git.xfce.org/apps/xfce4-screensaver/about/"
4SECTION = "x11/application"
5
6LICENSE = "GPLv2+ & LGPLv2+ "
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
9 "
10
11DEPENDS = "dbus-glib garcon gtk+3 libxklavier libxscrnsaver virtual/libx11 xfconf libwnck3"
12
13inherit xfce-app
14
15SRC_URI_append = " \
16 file://fix-cross-compile.patch \
17 file://fix-pam-config.patch \
18"
19SRC_URI[md5sum] = "1f093cde5af09e9fd9be017774e032ef"
20SRC_URI[sha256sum] = "586f1c78dd6745a20e9ce9f12d0117189d597ba7ad0c8ffcfcd25c9bb05f1d57"
21
22do_install_append() {
23 install -D -m 0644 ${S}/data/xfce4-screensaver.common-auth ${D}${sysconfdir}/pam.d/xfce4-screensaver
24}
25
26FILES_${PN} += "${datadir}/dbus-1 ${datadir}/desktop-directories"
27RDEPENDS_${PN} += "python3-core"