blob: 76abef0542fbc57dfaeec64e3227193b437292e8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Xfce4 Panel"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "garcon exo gtk+3 cairo virtual/libx11 libxml2 libwnck3 vala-native"
6
7inherit xfce gtk-doc gobject-introspection features_check remove-libtool mime-xdg
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
11SRC_URI[md5sum] = "177818d4a84633c1d489f703fffe905d"
12SRC_URI[sha256sum] = "ef22324d26e5af735134bb10f85b6e16525ac9f48be8d2f6b634142fbfcabbc9"
13SRC_URI += " \
14 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
15 file://0002-use-lxdm-to-replace-dm-tool.patch \
16"
17
18python populate_packages_prepend() {
19 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
20 plugin_name = d.expand('${PN}-plugin-%s')
21 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
22 '${PN} plugin for %s', extra_depends='', prepend=True,
23 aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
24 '${sysconfdir}/xdg/xfce/panel/%s-*',
25 '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
26 '${bindir}/*%s*'])
27}
28
29PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
30
31PACKAGES =+ "${PN}-gtk3"
32
33FILES_${PN} += "${libdir}/xfce4/panel/migrate \
34 ${libdir}/xfce4/panel/wrapper-1.0"
35
36FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la"
37
38FILES_${PN}-gtk3 = " \
39 ${libdir}/libxfce4panel-2.0${SOLIBS} \
40 ${libdir}/xfce4/panel/wrapper-2.0 \
41"