blob: 8da40f656ac85378c472566ca06ff019fad79a21 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001# reproducible_build.bbclass
2#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003# Sets SOURCE_DATE_EPOCH in each component's build environment.
4# Upstream components (generally) respect this environment variable,
5# using it in place of the "current" date and time.
6# See https://reproducible-builds.org/specs/source-date-epoch/
Brad Bishop316dfdd2018-06-25 12:45:53 -04007#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008# After sources are unpacked but before they are patched, we set a reproducible value for SOURCE_DATE_EPOCH.
9# This value should be reproducible for anyone who builds the same revision from the same sources.
Brad Bishop316dfdd2018-06-25 12:45:53 -040010#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011# There are 4 ways we determine SOURCE_DATE_EPOCH:
Brad Bishop316dfdd2018-06-25 12:45:53 -040012#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013# 1. Use the value from __source_date_epoch.txt file if this file exists.
14# This file was most likely created in the previous build by one of the following methods 2,3,4.
15# Alternatively, it can be provided by a recipe via SRC_URI.
Brad Bishop316dfdd2018-06-25 12:45:53 -040016#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017# If the file does not exist:
18#
19# 2. If there is a git checkout, use the last git commit timestamp.
20# Git does not preserve file timestamps on checkout.
Brad Bishop316dfdd2018-06-25 12:45:53 -040021#
22# 3. Use the mtime of "known" files such as NEWS, CHANGLELOG, ...
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023# This works for well-kept repositories distributed via tarball.
Brad Bishop316dfdd2018-06-25 12:45:53 -040024#
Brad Bishopa5c52ff2018-11-23 10:55:50 +130025# 4. Use the modification time of the youngest file in the source tree, if there is one.
26# This will be the newest file from the distribution tarball, if any.
27#
28# 5. Fall back to a fixed timestamp.
Brad Bishop316dfdd2018-06-25 12:45:53 -040029#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030# Once the value of SOURCE_DATE_EPOCH is determined, it is stored in the recipe's SDE_FILE.
31# If none of these mechanisms are suitable, replace the do_deploy_source_date_epoch task
32# with recipe-specific functionality to write the appropriate SOURCE_DATE_EPOCH into the SDE_FILE.
33#
34# If this file is found by other tasks, the value is exported in the SOURCE_DATE_EPOCH variable.
35# SOURCE_DATE_EPOCH is set for all tasks that might use it (do_configure, do_compile, do_package, ...)
Brad Bishop316dfdd2018-06-25 12:45:53 -040036
37BUILD_REPRODUCIBLE_BINARIES ??= '1'
38inherit ${@oe.utils.ifelse(d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1', 'reproducible_build_simple', '')}
39
40SDE_DIR ="${WORKDIR}/source-date-epoch"
41SDE_FILE = "${SDE_DIR}/__source_date_epoch.txt"
Brad Bishop00e122a2019-10-05 11:10:57 -040042SDE_DEPLOYDIR = "${WORKDIR}/deploy-source-date-epoch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040043
44SSTATETASKS += "do_deploy_source_date_epoch"
45
46do_deploy_source_date_epoch () {
Brad Bishop00e122a2019-10-05 11:10:57 -040047 mkdir -p ${SDE_DEPLOYDIR}
48 if [ -e ${SDE_FILE} ]; then
Andrew Geissler82c905d2020-04-13 13:39:40 -050049 echo "Deploying SDE from ${SDE_FILE} -> ${SDE_DEPLOYDIR}."
Brad Bishop00e122a2019-10-05 11:10:57 -040050 cp -p ${SDE_FILE} ${SDE_DEPLOYDIR}/__source_date_epoch.txt
Andrew Geissler82c905d2020-04-13 13:39:40 -050051 else
52 echo "${SDE_FILE} not found!"
Brad Bishop00e122a2019-10-05 11:10:57 -040053 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040054}
55
56python do_deploy_source_date_epoch_setscene () {
57 sstate_setscene(d)
Brad Bishop00e122a2019-10-05 11:10:57 -040058 bb.utils.mkdirhier(d.getVar('SDE_DIR'))
59 sde_file = os.path.join(d.getVar('SDE_DEPLOYDIR'), '__source_date_epoch.txt')
60 if os.path.exists(sde_file):
Andrew Geissler82c905d2020-04-13 13:39:40 -050061 target = d.getVar('SDE_FILE')
62 bb.debug(1, "Moving setscene SDE file %s -> %s" % (sde_file, target))
63 os.rename(sde_file, target)
64 else:
65 bb.debug(1, "%s not found!" % sde_file)
Brad Bishop316dfdd2018-06-25 12:45:53 -040066}
67
Brad Bishop00e122a2019-10-05 11:10:57 -040068do_deploy_source_date_epoch[dirs] = "${SDE_DEPLOYDIR}"
69do_deploy_source_date_epoch[sstate-plaindirs] = "${SDE_DEPLOYDIR}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040070addtask do_deploy_source_date_epoch_setscene
71addtask do_deploy_source_date_epoch before do_configure after do_patch
72
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080073def get_source_date_epoch_from_known_files(d, sourcedir):
74 source_date_epoch = None
75 newest_file = None
Brad Bishop316dfdd2018-06-25 12:45:53 -040076 known_files = set(["NEWS", "ChangeLog", "Changelog", "CHANGES"])
77 for file in known_files:
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080078 filepath = os.path.join(sourcedir, file)
Brad Bishop316dfdd2018-06-25 12:45:53 -040079 if os.path.isfile(filepath):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080080 mtime = int(os.lstat(filepath).st_mtime)
Brad Bishop316dfdd2018-06-25 12:45:53 -040081 # There may be more than one "known_file" present, if so, use the youngest one
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080082 if not source_date_epoch or mtime > source_date_epoch:
Brad Bishop316dfdd2018-06-25 12:45:53 -040083 source_date_epoch = mtime
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080084 newest_file = filepath
85 if newest_file:
86 bb.debug(1, "SOURCE_DATE_EPOCH taken from: %s" % newest_file)
Brad Bishop316dfdd2018-06-25 12:45:53 -040087 return source_date_epoch
88
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080089def find_git_folder(d, sourcedir):
90 # First guess: WORKDIR/git
91 # This is the default git fetcher unpack path
92 workdir = d.getVar('WORKDIR')
93 gitpath = os.path.join(workdir, "git/.git")
94 if os.path.isdir(gitpath):
95 return gitpath
96
97 # Second guess: ${S}
98 gitpath = os.path.join(sourcedir, ".git")
99 if os.path.isdir(gitpath):
100 return gitpath
101
102 # Perhaps there was a subpath or destsuffix specified.
103 # Go looking in the WORKDIR
104 exclude = set(["build", "image", "license-destdir", "patches", "pseudo",
105 "recipe-sysroot", "recipe-sysroot-native", "sysroot-destdir", "temp"])
106 for root, dirs, files in os.walk(workdir, topdown=True):
Brad Bishop316dfdd2018-06-25 12:45:53 -0400107 dirs[:] = [d for d in dirs if d not in exclude]
108 if '.git' in dirs:
Brad Bishop316dfdd2018-06-25 12:45:53 -0400109 return root
Brad Bishop316dfdd2018-06-25 12:45:53 -0400110
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800111 bb.warn("Failed to find a git repository in WORKDIR: %s" % workdir)
112 return None
113
114def get_source_date_epoch_from_git(d, sourcedir):
115 source_date_epoch = None
116 if "git://" in d.getVar('SRC_URI'):
117 gitpath = find_git_folder(d, sourcedir)
118 if gitpath:
119 import subprocess
120 source_date_epoch = int(subprocess.check_output(['git','log','-1','--pretty=%ct'], cwd=gitpath))
121 bb.debug(1, "git repository: %s" % gitpath)
122 return source_date_epoch
123
124def get_source_date_epoch_from_youngest_file(d, sourcedir):
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300125 if sourcedir == d.getVar('WORKDIR'):
126 # These sources are almost certainly not from a tarball
127 return None
128
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800129 # Do it the hard way: check all files and find the youngest one...
130 source_date_epoch = None
131 newest_file = None
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800132 for root, dirs, files in os.walk(sourcedir, topdown=True):
133 files = [f for f in files if not f[0] == '.']
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800134
135 for fname in files:
136 filename = os.path.join(root, fname)
137 try:
138 mtime = int(os.lstat(filename).st_mtime)
139 except ValueError:
140 mtime = 0
141 if not source_date_epoch or mtime > source_date_epoch:
142 source_date_epoch = mtime
143 newest_file = filename
144
145 if newest_file:
146 bb.debug(1, "Newest file found: %s" % newest_file)
147 return source_date_epoch
148
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300149def fixed_source_date_epoch():
150 bb.debug(1, "No tarball or git repo found to determine SOURCE_DATE_EPOCH")
151 return 0
152
Andrew Geissler82c905d2020-04-13 13:39:40 -0500153python create_source_date_epoch_stamp() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400154 epochfile = d.getVar('SDE_FILE')
Andrew Geissler82c905d2020-04-13 13:39:40 -0500155 # If it exists we need to regenerate as the sources may have changed
Brad Bishop316dfdd2018-06-25 12:45:53 -0400156 if os.path.isfile(epochfile):
Andrew Geissler82c905d2020-04-13 13:39:40 -0500157 bb.debug(1, "Deleting existing SOURCE_DATE_EPOCH from: %s" % epochfile)
158 os.remove(epochfile)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800159
160 sourcedir = d.getVar('S')
161 source_date_epoch = (
162 get_source_date_epoch_from_git(d, sourcedir) or
163 get_source_date_epoch_from_known_files(d, sourcedir) or
164 get_source_date_epoch_from_youngest_file(d, sourcedir) or
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300165 fixed_source_date_epoch() # Last resort
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800166 )
Brad Bishop316dfdd2018-06-25 12:45:53 -0400167
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800168 bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400169 bb.utils.mkdirhier(d.getVar('SDE_DIR'))
170 with open(epochfile, 'w') as f:
171 f.write(str(source_date_epoch))
172}
173
Andrew Geissler82c905d2020-04-13 13:39:40 -0500174def get_source_date_epoch_value(d):
175 cached = d.getVar('__CACHED_SOURCE_DATE_EPOCH')
176 if cached:
177 return cached
178
179 epochfile = d.getVar('SDE_FILE')
180 source_date_epoch = 0
181 if os.path.isfile(epochfile):
182 with open(epochfile, 'r') as f:
183 s = f.read()
184 try:
185 source_date_epoch = int(s)
186 except ValueError:
187 bb.warn("SOURCE_DATE_EPOCH value '%s' is invalid. Reverting to 0" % s)
188 source_date_epoch = 0
189 bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch)
190 else:
191 bb.debug(1, "Cannot find %s. SOURCE_DATE_EPOCH will default to %d" % (epochfile, source_date_epoch))
192
193 d.setVar('__CACHED_SOURCE_DATE_EPOCH', str(source_date_epoch))
194 return str(source_date_epoch)
195
196export SOURCE_DATE_EPOCH ?= "${@get_source_date_epoch_value(d)}"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400197BB_HASHBASE_WHITELIST += "SOURCE_DATE_EPOCH"
198
199python () {
200 if d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1':
Andrew Geissler82c905d2020-04-13 13:39:40 -0500201 d.appendVarFlag("do_unpack", "postfuncs", " create_source_date_epoch_stamp")
Brad Bishop316dfdd2018-06-25 12:45:53 -0400202}