blob: 56f2d4b91516f5c88f376b1bb5c42f23fed2380d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
2DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
5
6require opensbi-payloads.inc
7
8inherit autotools-brokensep deploy
9
10SRCREV = "ac5e821d50be631f26274765a59bc1b444ffd862"
11SRC_URI = "git://github.com/riscv/opensbi.git \
12 file://0001-Makefile-Don-t-specify-mabi-or-march.patch \
13 "
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D}"
18# If RISCV_SBI_PAYLOAD is set then include it as a payload
19EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)}"
20
21# Required if specifying a custom payload
22do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
23
24do_install_append() {
25 # In the future these might be required as a dependency for other packages.
26 # At the moment just delete them to avoid warnings
27 rm -r ${D}/include
28 rm -r ${D}/platform/${RISCV_SBI_PLAT}/lib
29 rm -r ${D}/platform/${RISCV_SBI_PLAT}/firmware/payloads
30 rm -r ${D}/lib
31}
32
33do_deploy () {
34 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
35 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
36 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
37}
38
39addtask deploy before do_build after do_install
40
41FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
42FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
43FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
44
45COMPATIBLE_HOST = "(riscv64|riscv32).*"
46INHIBIT_PACKAGE_STRIP = "1"
47
48SECURITY_CFLAGS = ""