blob: 3251d0f05be8a20327faa7ac41576f8fbf9b8751 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "U-Boot libraries and tools to access environment"
2DEPENDS += "mtd-utils"
3
4DESCRIPTION = "This package contains tools and libraries to read \
5and modify U-Boot environment. \
6It provides a hardware-independent replacement for fw_printenv/setenv utilities \
7provided by U-Boot"
8
9HOMEPAGE = "https://github.com/sbabic/libubootenv"
10LICENSE = "LGPL-2.1"
11LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
12SECTION = "libs"
13
14PV = "0.2+git${SRCPV}"
15SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
16SRCREV = "f4b9cde3815abe84a98079cedd515283ea08c16b"
17
18S = "${WORKDIR}/git"
19
20inherit cmake lib_package
21
22EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
23
24PROVIDES += "u-boot-fw-utils"
25RPROVIDES_${PN}-bin += "u-boot-fw-utils"
26
27BBCLASSEXTEND = "native"