blob: e9596ce1a4dad26e2c026807c685be8b96b0d707 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0"
11
12SRC_URI[archive.md5sum] = "a758ca62bd54982a798b39c744cbf783"
13SRC_URI[archive.sha256sum] = "8ca1f86f23a76b5c7640624f7d5490705c78e81375e1741c9a1c41ce7f8f7ff7"
14
15PACKAGECONFIG ??= "gnutls"
16
17PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
18PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
19PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
20
21EXTRA_OEMESON = "-Dgnome_proxy=disabled"
22
23GNOMEBASEBUILDCLASS = "meson"
24inherit gnomebase gettext upstream-version-is-even gio-module-cache
25
26FILES_${PN} += "\
27 ${libdir}/gio/modules/libgio*.so \
28 ${datadir}/dbus-1/services/ \
29 ${systemd_user_unitdir} \
30 "
31FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
32FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"
33
34BBCLASSEXTEND = "native"