blob: 43b2547fc69c21361c966dbe6189fb07dd19636b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
6LICENSE = "BSD-2-Clause"
7
8DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
9BBCLASSEXTEND = "native nativesdk"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067"
12
13SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \
14 file://run-ptest \
15 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
16 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
17 file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
18 "
19
20SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
21SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
22
23# Flex has moved to github from 2.6.1 onwards
24UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
25UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
26
27inherit autotools gettext texinfo ptest
28
29M4 = "${bindir}/m4"
30M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
31EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
32EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
33
34EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
35
36do_install_append_class-native() {
37 create_wrapper ${D}/${bindir}/flex M4=${M4}
38}
39
40do_install_append_class-nativesdk() {
41 create_wrapper ${D}/${bindir}/flex M4=${M4}
42}
43
44PACKAGES =+ "${PN}-libfl"
45
46FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
47
48RDEPENDS_${PN} += "m4"
49RDEPENDS_${PN}-ptest += "bash gawk make"
50
51do_compile_ptest() {
52 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
53}
54
55do_install_ptest() {
56 mkdir -p ${D}${PTEST_PATH}/build-aux/
57 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
58 cp -r ${S}/tests/* ${D}${PTEST_PATH}
59 cp -r ${B}/tests/* ${D}${PTEST_PATH}
60 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
61 -e 's|${DEBUG_PREFIX_MAP}||g' \
62 -e 's:${HOSTTOOLS_DIR}/::g' \
63 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
64 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
65 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
66 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
67 -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
68 -i ${D}${PTEST_PATH}/Makefile
69}
70# The uninative loader is different on i386 & x86_64 hosts. Since it is only
71# being replaced with /bin/false anyway, it doesn't need to be part of the task
72# hash
73do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
74
75# Not Apache Flex, or Adobe Flex, or IBM Flex.
76CVE_PRODUCT = "flex_project:flex"