blob: 698016ba4c243822334fee275baacb8efd0c1c2c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88"
9
10PYPI_PACKAGE = "python-magic"
11
12inherit pypi setuptools3
13
14SRC_URI[md5sum] = "e384c95a47218f66c6501cd6dd45ff59"
15SRC_URI[sha256sum] = "f3765c0f582d2dfc72c15f3b5a82aecfae9498bd29ca840d72f37d7bd38bfcd5"
16
17RDEPENDS_${PN} += "file"
18
19BBCLASSEXTEND = "native"