blob: a7a1f0ff1a5f61835dce10c2c840ce7a08c1ec15 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001LICENSE = "LGPLv2.1 & GPLv2"
2LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
3 file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
4
5SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \
Andrew Geissler82c905d2020-04-13 13:39:40 -05006 file://0001-architecture-Recognise-RISCV-32-RISCV-64.patch \
7 file://mips64.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -04008"
9
10SRC_URI_append_libc-musl = " \
11 file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
12 file://0002-musl-does-not-provide-printf-h.patch \
13 file://0003-musl-does-not-provide-canonicalize_file_name.patch \
14 "
15
16
17# Modify these as desired
18PV = "233+git${SRCPV}"
19SRCREV = "fe1c5e41e6bdb78043dad8fa863fc2df66d1dadf"
20
21S = "${WORKDIR}/git"
22
23DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
24
Brad Bishop6dbb3162019-11-25 09:41:34 -050025inherit pkgconfig autotools systemd features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040026
27REQUIRED_DISTRO_FEATURES = "systemd"
28
29SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
30
31do_configure_prepend() {
32 # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
33 rm -f ${S}/m4/intltool.m4
34}
35
36FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
37
Brad Bishop79641f22019-09-10 07:20:22 -040038EXTRA_OECONF = " --with-rootprefix=${root_prefix} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040039 --with-rootlibdir=${base_libdir}"