blob: d6eafaa8dccfa9d8861af0049dfb84b07ecaa037 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "fbb24aa414ab9a11ff66d351b5b8493b"
15SRC_URI[sha256sum] = "0b25a46b61bc6e26f56dcb973fc28acea159e2c32c9d6da42c0fa8d1a6339829"
16
17UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
18
19inherit autotools ptest bash-completion
20
21RDEPENDS_${PN}-ptest += "make"
22
23do_compile_ptest() {
24 oe_runmake buildtest-TESTS
25}
26
27do_install_ptest () {
28 cp ${B}/Makefile ${D}${PTEST_PATH}
29 install ${B}/test-cmdline ${D}${PTEST_PATH}
30 install ${B}/test-features ${D}${PTEST_PATH}
31 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
32 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
33}