Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Internationalized Domain Name support library" |
| 2 | DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group." |
| 3 | HOMEPAGE = "http://www.gnu.org/software/libidn/" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "(GPLv2+ | LGPLv3) & GPLv3+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d834ea7d480438ada04e5d846152395 \ |
| 7 | file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ |
| 8 | file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 9 | file://src/idn2.c;endline=16;md5=426b74d6deb620ab6d39c8a6efd4c13a \ |
| 10 | file://lib/idn2.h.in;endline=27;md5=c2cd28d3f87260f157f022eabb83714f" |
| 11 | |
| 12 | SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz" |
| 13 | SRC_URI[md5sum] = "01c5084995295e519f95978ae9785ee0" |
| 14 | SRC_URI[sha256sum] = "e1cb1db3d2e249a6a3eb6f0946777c2e892d5c5dc7bd91c74394fc3a01cab8b5" |
| 15 | |
| 16 | DEPENDS = "virtual/libiconv libunistring" |
| 17 | |
| 18 | inherit pkgconfig autotools gettext texinfo gtk-doc lib_package |
| 19 | |
| 20 | EXTRA_OECONF += "--disable-rpath \ |
| 21 | --with-libunistring-prefix=${STAGING_EXECPREFIXDIR} \ |
| 22 | " |
| 23 | |
| 24 | do_install_append() { |
| 25 | # Need to remove any duplicate whitespace too for reproducibility |
| 26 | sed -i -e 's|-L${STAGING_LIBDIR}||' -e 's/ */ /g' ${D}${libdir}/pkgconfig/libidn2.pc |
| 27 | } |
| 28 | |
| 29 | LICENSE_${PN} = "(GPLv2+ | LGPLv3)" |
| 30 | LICENSE_${PN}-bin = "GPLv3+" |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |