blob: ca359a15074c2442b6f69785924543fdce11a6df [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "msmtp is an SMTP client"
2DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
3HOMEPAGE = "https://marlam.de/msmtp/"
4SECTION = "console/network"
5
6LICENSE = "GPLv3"
7DEPENDS = "zlib gnutls"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11UPSTREAM_CHECK_URI = "https://marlam.de/msmtp/download/"
12
13SRC_URI = "https://marlam.de/${BPN}/releases/${BP}.tar.xz"
14SRC_URI[md5sum] = "016e432d12e12dc5d73960e2bc67f0fb"
15SRC_URI[sha256sum] = "eccb53e48f025f7e6f60210316df61cf6097a491728341c1e375fc1acc6459e5"
16
17inherit gettext autotools update-alternatives pkgconfig
18
19EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn"
20
21ALTERNATIVE_${PN} = "sendmail"
22# /usr/lib/sendmial is required by LSB core test
23ALTERNATIVE_${PN}_linuxstdbase = "sendmail usr-lib-sendmail"
24ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
25ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
26ALTERNATIVE_TARGET[usr-lib-sendmail] = "${bindir}/msmtp"
27ALTERNATIVE_LINK_NAME[usr-lib-sendmail] = "/usr/lib/sendmail"
28ALTERNATIVE_PRIORITY = "100"