blob: 3486be1b03ceb63f3c3d2213184828ec239b0459 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
10 "
11SRC_URI[md5sum] = "a558fc7fb9d0a851afe6de09080b5401"
12SRC_URI[sha256sum] = "9fe19548c87aa1a1b9b2be3b359ec2621b88bcb16998b77527549a7736f65494"
13
14DEPENDS = "coreutils-native"
15
16PROVIDES = "stress"
17RPROVIDES_${PN} = "stress"
18RREPLACES_${PN} = "stress"
19RCONFLICTS_${PN} = "stress"
20
21inherit bash-completion
22
23do_install() {
24 oe_runmake DESTDIR=${D} install
25}