blob: ebe6cb0dbdd7da1261ee0e329d5e4f33344c9fd8 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2 \
Brad Bishopc342db32019-05-15 21:57:59 -040010 file://musl_dirent.patch \
11"
12
13SRC_URI[md5sum] = "17917356fff5cb4bd3cd5a6c3e727b05"
14SRC_URI[sha256sum] = "e4bb9e08e12e7fa9f11fef544efc85e59ba34538593d9ad38148c7ca2bfbb566"
15
16inherit autotools gettext texinfo
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
20
21PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
22
23EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
24
Andrew Geissler82c905d2020-04-13 13:39:40 -050025CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no"
26
Brad Bishopc342db32019-05-15 21:57:59 -040027# Let aclocal use the relative path for the m4 file rather than the
28# absolute since tar has a lot of m4 files, otherwise there might
29# be an "Argument list too long" error when it is built in a long/deep
30# directory.
31acpaths = "-I ./m4"
32
33do_install () {
34 autotools_do_install
35 ln -s tar ${D}${bindir}/gtar
36}
37
38do_install_append_class-target() {
39 if [ "${base_bindir}" != "${bindir}" ]; then
40 install -d ${D}${base_bindir}
41 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
42 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
43 rmdir ${D}${bindir}/
44 fi
45}
46
47PACKAGES =+ "${PN}-rmt"
48
49FILES_${PN}-rmt = "${sbindir}/rmt*"
50
51inherit update-alternatives
52
53ALTERNATIVE_PRIORITY = "100"
54
55ALTERNATIVE_${PN} = "tar"
56ALTERNATIVE_${PN}-rmt = "rmt"
57ALTERNATIVE_${PN}_class-nativesdk = ""
58ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
59
60ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
61ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
62
63PROVIDES_append_class-native = " tar-replacement-native"
64NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
65
66BBCLASSEXTEND = "native nativesdk"