blob: 92cea83bc1951e1caffe65da9747c9c7ba8876d3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
21SRC_URI[md5sum] = "aef13eb48e01a47d1416d97462a22a11"
22SRC_URI[sha256sum] = "6c57eb642d828af2411aa38f55dc10111e8c98976dbab8fd62e48629401eaea5"
23
24UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
25
26DEPENDS = "libdrm virtual/mesa"
27
28inherit meson pkgconfig features_check
29
30REQUIRED_DISTRO_FEATURES = "opengl"
31
32PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
33PACKAGECONFIG[x11] = "-Dwith_x11=yes, -Dwith_x11=no,virtual/libx11 libxext libxfixes"
34PACKAGECONFIG[wayland] = "-Dwith_wayland=yes, -Dwith_wayland=no,wayland-native wayland"
35
36PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
37
38RDEPENDS_${PN}-x11 =+ "${PN}"
39RDEPENDS_${PN}-glx =+ "${PN}-x11"
40
41FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
42FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
43FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"