blob: 0ee8abcc094154c15e698cb65ccd6b8b5e14e3c5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
18SRC_URI += "file://run-ptest \
19 file://0001-Fix-build-reproducibility.patch"
20SRC_URI[archive.md5sum] = "c75cc5b833d934d98e83343832e20e5d"
21SRC_URI[archive.sha256sum] = "66a5b6cc13db73efed67b8e933584509f8ddb7b10a8a40c3850ca4a985ea1b1f"
22
23DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
26 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
27
28PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
29PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
30PACKAGECONFIG[thai] = ",,libthai"
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33GIR_MESON_OPTION = 'introspection'
34
35do_configure_prepend_toolchain-clang() {
36 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
37}
38
39LEAD_SONAME = "libpango-1.0*"
40
41FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
42
43RDEPENDS_${PN}-ptest += "cantarell-fonts"
44RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
45
46RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
47 pango-module-basic-fc pango-module-arabic-lang"
48
49BBCLASSEXTEND = "native nativesdk"