blob: 6fff096a3758bbcfa960b4822ee76cb51efb520f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
6
7inherit module
8
9COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
10
11SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
13 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
14 "
15
16SRC_URI[md5sum] = "2e3bc8cfb264fa13f374618b46f170e7"
17SRC_URI[sha256sum] = "8a42240813b8fd1d001835cd6f5ec687f7d7f3b26070d4e21604c35a51a6441d"
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20
21EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
22
23do_install_append() {
24 # Delete empty directories to avoid QA failures if no modules were built
25 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
26}
27
28python do_package_prepend() {
29 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
30 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
31}
32
33BBCLASSEXTEND = "devupstream:target"
34LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
35DEFAULT_PREFERENCE_class-devupstream = "-1"
36SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.11 \
37 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
38 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
39 "
40SRCREV_class-devupstream = "17c413953603f063f2a9d6c3788bec914ce6f955"
41PV_class-devupstream = "2.11.2+git${SRCPV}"
42S_class-devupstream = "${WORKDIR}/git"
43SRCREV_FORMAT ?= "lttng_git"