blob: 0c20abe6d5d5e47ff2a70ea8f05e72ec9a4bbf39 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Userspace RCU (read-copy-update) library"
2HOMEPAGE = "http://lttng.org/urcu"
3BUGTRACKER = "http://lttng.org/project/issues"
4
5LICENSE = "LGPLv2.1+ & MIT-style"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \
7 file://include/urcu/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \
8 file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b"
9
10SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2"
11
12SRC_URI[md5sum] = "d923a42ce38e33e883313003c8afd559"
13SRC_URI[sha256sum] = "409b1be506989e1d26543194df1a79212be990fe5d4fd84f34f019efed989f97"
14
15S = "${WORKDIR}/userspace-rcu-${PV}"
16inherit autotools multilib_header
17
18CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT"
19
20do_install_append() {
21 oe_multilib_header urcu/config.h
22}