blob: 57774cbdf7d88d8efb727a75d8965ef01941ee11 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "sdbus-c++"
2DESCRIPTION = "High-level C++ D-Bus library designed to provide easy-to-use yet powerful API in modern C++"
3
4SECTION = "libs"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1803fa9c2c3ce8cb06b4861d75310742"
8
9inherit cmake pkgconfig systemd ptest
10
11PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \
12 ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
13PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap"
14PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
15PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF"
16
17DEPENDS += "expat"
18
19SRCREV = "5121d46eed42231285c18d317a9f48e0b2849d5e"
20SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master"
21SRC_URI += "file://run-ptest"
22
23EXTRA_OECMAKE = "-DBUILD_CODE_GEN=ON \
24 -DBUILD_DOC=ON \
25 -DBUILD_DOXYGEN_DOC=OFF"
26
27S = "${WORKDIR}/git"
28
29FILES_${PN}_remove = "${sysconfdir}"
30FILES_${PN}-ptest += "${sysconfdir}/dbus-1/system.d/"
31FILES_${PN}-ptest += "${libdir}/${BPN}/tests"
32FILES_${PN}-dev += "${bindir}/sdbus-c++-xml2cpp"