blob: 6b73506c2aab0389bb4f16590cb526814b0be545 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Dispatcher service for systemd-networkd connection status changes"
2DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \
3more limited in the types of events it supports due to the limited nature of \
4systemd-networkd(8)."
5AUTHOR = "Clayton Craft and others"
6
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
9
Brad Bishop8410d612019-11-25 09:40:59 -050010inherit features_check systemd
Brad Bishop00ab2372019-10-14 11:06:18 -040011
12RDEPENDS_${PN} = "python3-pygobject python3-dbus"
13REQUIRED_DISTRO_FEATURES = "systemd"
Brad Bishopc342db32019-05-15 21:57:59 -040014
15SRC_URI = "https://gitlab.com/craftyguy/networkd-dispatcher/-/archive/${PV}/networkd-dispatcher-${PV}.tar.bz2"
16SRC_URI[md5sum] = "304d7dcc21331ea295e207f8493cb8d8"
17SRC_URI[sha256sum] = "21f84c3646a043329dc64787e4e58dfce592b2559b0e3069af82c469805660c2"
18
Brad Bishop00ab2372019-10-14 11:06:18 -040019SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE_${PN} = "networkd-dispatcher.service"
21SYSTEMD_AUTO_ENABLE = "disable"
22
Brad Bishopc342db32019-05-15 21:57:59 -040023# Nothing to build, just a python script to install
24do_configure[noexec] = "1"
25do_compile[noexec] = "1"
26
27do_install() {
Brad Bishop665fd022019-08-26 01:32:28 -040028 install -D -m 0755 ${S}/networkd-dispatcher ${D}${bindir}/networkd-dispatcher
Brad Bishopc342db32019-05-15 21:57:59 -040029 install -D -m 0644 ${S}/networkd-dispatcher.service ${D}/${systemd_system_unitdir}/networkd-dispatcher.service
30 install -D -m 0644 ${S}/networkd-dispatcher.conf ${D}/${sysconfdir}/conf.d/networkd-dispatcher.conf
31}