blob: 2fa754e79daf2e96005c2f940077c2649522839e [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-2.1"
Brad Bishop90ca7472019-08-20 09:15:15 -04007LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
Brad Bishop26bdd442019-08-16 17:08:17 -04008
Brad Bishop90ca7472019-08-20 09:15:15 -04009# Upstream renamed this package to gnome-themes-extra at some point
10BPN = "gnome-themes-extra"
11
Brad Bishop8410d612019-11-25 09:40:59 -050012inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check
Brad Bishop26bdd442019-08-16 17:08:17 -040013
14ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
15
16DEPENDS += "intltool-native gtk+"
17
Brad Bishop90ca7472019-08-20 09:15:15 -040018SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
19SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
Brad Bishop26bdd442019-08-16 17:08:17 -040020
21EXTRA_OECONF = "--disable-gtk3-engine"
22
23do_install_append() {
24 # Only building Adwaita, remove highcontrast files
25 rm -rf ${D}${prefix}/share/themes/HighContrast \
26 ${D}${prefix}/share/icons
27
28 # The libtool archive file is unneeded with shared libs on modern Linux
29 rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
30}
31
32# There could be gnome-theme-highcontrast as well but that requires
33# gtk+3 and includes lots of icons (is also broken with B != S).
34PACKAGES += "gnome-theme-adwaita \
35 gnome-theme-adwaita-dark \
36 "
37
38FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
39 ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
40
41FILES_gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
42RDEPENDS_gnome-theme-adwaita-dark = "gnome-theme-adwaita"
43
44# gnome-themes-standard is empty and doesn't exist
45RDEPENDS_${PN}-dev = ""