blob: 65f72747cc818494e2ef4483844edeb5a89f8a6a [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "OpenGL frontend to Freetype 2"
2HOMEPAGE = "https://sourceforge.net/projects/ftgl/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=527a83e92c7bf363025380eec05df6e4"
5
Brad Bishop8410d612019-11-25 09:40:59 -05006inherit autotools pkgconfig features_check
Brad Bishop19323692019-04-05 15:28:33 -04007
Brad Bishopc342db32019-05-15 21:57:59 -04008REQUIRED_DISTRO_FEATURES = "opengl x11"
Brad Bishop19323692019-04-05 15:28:33 -04009
10DEPENDS += " \
11 freetype \
12 freeglut \
13"
14
15SRC_URI = " \
16 ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
17 file://0001-use-pkg-config-to-find-freetype2.patch \
18 file://0002-Makefile.am-remove-useless-and-breaking-code.patch \
19 file://0001-Explicit-typecast-to-avoid-implicit-double-to-float-.patch \
20"
21SRC_URI[md5sum] = "c7879018cde844059495b3029b0b6503"
22SRC_URI[sha256sum] = "521ff7bd62c459ff5372e269c223e2a6107a6a99a36afdc2ae634a973af70c59"
23
24S = "${WORKDIR}/ftgl-2.1.3~rc5"
25
26# undefined reference to symbol 'sin@@GLIBC_2.4'
27CFLAGS += "-lm"